3 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Бесшовный WiFi Роуминг на Роутерах Keenetic; Как Настроить Mesh Сеть Дома Своими Руками в Квартире

Бесшовный WiFi Роуминг на Роутерах Keenetic — Как Настроить Mesh Сеть Дома Своими Руками в Квартире

В этой статье поговорим о том, как настроить бесшовный WiFi роуминг между 2 роутерами Keenetic дома в квартире на основе технологии mesh сетей. Ранее для увеличения расстояния действия вай-фай можно было установить на оборудование Кинетик дополнительный компонент для усиления сигнала интернета, то можно подключить роутер через роутер и использовать его в качестве повторителя. Однако в новой версии прошивки мы получаем не просто большую площадь покрытия, но и полноценную mesh сеть с бесшовным роумингом WiFi и контроллером нагрузки по всей квартире. Причем организовать ее сможет абсолютно любой своими руками из двух обычных роутером Keenetic.

Какие существуют способы решения такой задачи?

Вариант 1
Установить множество несвязанных между собой WiFi точек доступа и вещать разные WiFi сети
Результат:
1. Управлять таким «хозяйством» очень сложно, неудобно и отнимает много времени.
2. При перемещении по территории Вам придется вручную переключать мобильное устройство между сетями, тратить время и нервы
3. Практически невозможно отстроить качественный WiFi в виду большой зашумленности разными точками доступа.

Вариант 2
Раздавать одну WiFi сеть, используя много однотипных точек доступа в режиме WDS
Результат:
1. Крайне нестабильный режим работы WDS у большинства производителей бюджетных и средних моделей WiFi точек доступа
2. Потеря связи со стороны устройства клиента, сбои в работе

Принцип действия бесшовного wi-fi

В основе работы системы – наличие контроллера, осуществляющего управление зависимыми точками доступа, используя многочисленные функциональные возможности, включая:

  • быстрый роуминг, обеспечивающий бесперебойную связь при перемещении и исключающий прерывание разговора при пересечении зональных границ – устройство прослеживает путь вашего приемника (телефона, планшета и др.) и своевременно перенаправляет сигнал от ближайшей точки доступа;
  • корректировку мощности сигнала в соответствии с количеством и потребностями клиентов;
  • наблюдение и регулирование уровня нагрузки между зависимыми точками доступа;
  • восстановление связи при частичных неисправностях, увеличивая зоны покрытия за счет действующего оборудования;
  • определение временных учетных данных пользователей из категории гостевого доступа, том числе – обеспечивая распечатку таких данных.

Возможности бесшовного wi-fi роуминга

Несмотря на насыщенность современного рынка интернет-услуг оборудования для бесшовного роуминга, в качестве образца функциональности и надежности можно выделить продукцию ZyXEL (Тайвань).

Расширенный функционал и техническое совершенство современного оборудования компании, обеспечивают качественную беспроводную связь, предназначенную для применения, как в небольших организациях, так и в крупных корпорациях.

Для формирования расширенных сетей с количеством точек доступа до 200 и более, рассчитанных на обслуживание более чем 500 пользователей, идеальный вариант – контроллер типа ZyXEL NXC5200. Он обеспечивает высокую скорость сигнала Wi-Fi, содержит антивирусное программное обеспечение, защиту от проникновения сторонней информации и другие технические возможности, необходимые для безопасной работы системы.

Схема работы Wi-Fi сети

Передовые технологии ZyXELAP Controller (APC) обеспечивают масштабирование существующихна предприятиях сетей Wi-Fi при необходимости расширения производства и управленческого аппарата, оптимизируя расходы на техническое переоснащение.

Оборудование Zyxel

Построение бесшовного Wi-Fi, безусловно, обходится дороже, нежели аналогов с автономными точками доступа, используемых в бюджетных образцах UniFiили Mikrotik. Однако затраты на новейшее оборудование, обеспечивающее бесшовный высокоскоростной Wi-Fi роуминг со стабильными качественным покрытием, окупается за счет организации эффективной работы пользователей и улучшения показателей сети в целом.

Читать еще:  Настройка ноутбука на максимальную производительность windows 10

Оборудование Ubiquiti

Внедрение новых интернет-технологий – основное направление деятельности наших специалистов: решим любые вопросы, касающиеся проектирования, обустройства или масштабирования сети бесшовного Wi-Fi роуминга в целях оптимизации и удобства пользования беспроводной сетью в Вашем доме.

Ubiquiti UniFi

Относительно дешёвое и при этом мощное оборудование, способное связывать сразу несколько объектов. Ядром системы выступает программное обеспечение, которое работает практически со всеми современными ОС.

Ubiquiti UniFi

TP-Link Auranet

TP-Link один из лидеров среди компаний, которые занимаются производством сетевого оборудование. У TP-Link контроллер может быть как программным, так и аппаратным. Огромный выбор оборудования, как в бюджетном сегменте для дома, так и корпоративном для построения нагруженных бесшовных wifi сетей.

TP-Link Auranet

MikroTik CAPsMAN

Один из самых популярных бюджетных вариантов. Несмотря на это, достаточно сложный в настройках, при этом в сети достаточно много инструкций, обзоров настроек.

MikroTik CAPsMAN

Можно ли обойтись без роуминга? Возможно. Но, вряд ли Вы захотите возвращаться в сеть, где есть потери соединения, повторные голосовые или видеовызовы из-за некачественного соединения.

Монтаж, строительство бесшовной wifi сети

Если Вам требуется построить качественную бесшовную вай фай сеть, звоните по телефонам или оставляйте заявку на сайте.

Если у Вас есть какие-либо вопросы или необходим выезд на объект для расчета, Вы можете позвонить мне по телефонам.

Быстрая настройка готовым скриптом

Достаточно вставить скрипт в терминал нужного микротика.

Главный роутер:

/interface bridge add name=bridgeCAP
/caps-man channel add band=2ghz-b/g/n frequency=2457 name=hs-channel1 tx-power=20 control-channel-width=20
/caps-man datapath add bridge=hs-bridge name=hs-datapath1 client-to-client-forwarding=yes
/caps-man configuration add channel=hs-channel1 datapath=hs-datapath1 mode=ap name=hs-cfg1 rx-chains=0,1,2 tx-chains=0,1,2 ssid=WiFi-CAPs
/caps-man manager set enabled=yes
/caps-man provisioning add action=create-dynamic-enabled master-configuration=hs-cfg1
/interface wireless cap set enabled=yes interfaces=wlan1 discovery-interface=bridgeCAP bridge=none

Второй, третий и т.д. роутер:

/ip dns set allow-remote-requests=yes servers=8.8.8.8,208.67.222.222
/interface bridge add name=hs-bridge
/ip dhcp-client add dhcp-options=hostname,clientid disabled=no interface=hs-bridge
/interface wireless cap set discovery-interfaces=hs-bridge enabled=yes interfaces=wlan1
/interface bridge port add bridge=hs-bridge interface=ether3
/interface bridge port add bridge=hs-bridge interface=ether4
/interface bridge port add bridge=hs-bridge interface=ether5
/interface bridge port add bridge=hs-bridge interface=ether2
/interface bridge port add bridge=hs-bridge interface=ether1

Настройка модуля CAPsMAN

В меню появился новый пункт CAPsMAN. Заходим в него контроллер и включаем контроллер ( CAPsMAN — вкладка InterFace — Manage — галка в пункте Enable).

Прописываем нужные нам настройки WiFi канала на вкладке Channel.

Потом — настройки Datapath, здесь только название и выбираем наш bridge1.

Если мы ставим галочку local-forwarding, то передаем управление трафиком непосредственно точкам доступа. Если галочка снята, то управление трафиком берет на себя контроллер.

Далее выставляем настройки безопасности на вкладке Security

Далее на вкладке Configuration создаем конфигурацию. В первом разделе Wireless прописываем имя конфигурации, режим работы, SSID нашей сети и активируем все каналы передачи.

На остальных вкладках просто выбираем те настройки Channel, Datapath и Security, которые мы создали ранее, таким образом объединяя их в одну конфигурацию. В принципе, можно было создавать их и здесь, но для сложных случаев все же удобнее это делать отдельно.

Теперь нам нужна вкладка Provisioning или «развертывание». Здесь мы прописываем правило развертывания конфигурации. Первое поле (Radio MAC) не трогаем, в поле Action указываем, что будут создаваться включенные по умолчанию динамические интерфейсы.

Как подобрать оборудование

Сейчас многие производители предлагают доступное оборудование бесшовного Wi-Fi для квартиры, небольшого офиса. Приведем несколько наиболее распространенных решений:

  • лидером по популярности среди оборудования домашних сетей является Ubiquiti UniFi — они предлагают сравнительно недорогие ТД и программный контроллер, устанавливаемый на любом компьютере сети;
  • линейка TP-LINK Auranet;
  • Mikrotik CAPsMAN — контроллер, устанавливается на маршрутизатор, затем может присоединить любые модели беспроводных сетевых устройств Mikrotik;
  • ТД, репитеры, контроллеры, коммутаторы Edimax.

Решения премиум-класса — Cisco и Zyxel

Cisco и Zyxel предлагают мощные многофункциональные устройства со множеством вспомогательных функций: автоматическая балансировка нагрузки, противодействие помехам, приоритезация трафика. Например, линейка устройств Cisco Aironet.

Читать еще:  Как убрать надоедливую рекламу в интернете

Существует интересное “коробочное” решение Zyxel Multy X, состоящее из 3х точек доступа, настраиваемых специальным приложением со смартфона. Но в нем есть “нюанас”, который может быть проблемой для высоконгруженных задач — просмотра потокового видео в HD 4K, или BlueRay формата. Нюанс в том, что точки между собой не соединены классической сетью из медных каблей, а раздает Wifi от точки к точки через отдельный приемник внутри. При этом, если точки будут работать последовательно, шумы между ними будут приводить к потере скорости во всей сети.

Подбирая оборудование, обратите внимание — создание бесшовной Wi-Fi сети требует специального оборудования, поддерживающего данную технологию. Рекомендация общего характера — лучше использовать меньшее число более мощных сетевых устройств, чем множество маломощных.

2. Отключаем всю рекламу в интернете на всех устройствах

Мы уже давно пользуемся блокировщиками рекламы, но при этом терпим некоторые неудобства, самое основное из которых — не блокируется реклама в играх на смартфонах. Кроме этого, модуль Adblock, устанавливаемый в Chrome, сильно тормозит загрузку сайтов, а Яндекс Директ и вовсе не блокирует. Недавно Adguard, второй крупнейший сервис по блокировке интернет-рекламы, предложил лёгкое решение от назойливых баннеров — антирекламные DNS серверы.

Суть этой технологии в следующем: реклама вырезается не в момент загрузки web-страниц, проходя через прокси, а в момент обработки DNS-запросов, то есть когда браузер пытается достучаться до сервера с именем вроде an.yandex.ru. Образно говоря, когда интернет-браузер пытается вызвать адрес рекламного блока, сервер Adguard говорит: «вот он я», и выдаёт нули вместо баннеров. Конечно, сама технология намного сложнее, она учитывает дизайн рекламы, чтобы не рушить разметку веб-страниц, но смысл тот же: в отличии от Adblock, антирекламные DNS-серверы Adguard не тратят ресурсы клиентского устройства и работают значительно быстрее.

Преимущества Adguard DNS:

  • Блокировка работает для всех устройств в домашней сети: для смартфонов, ноутбуков, компьютеров.
  • Блокирует рекламу в играх
  • Не определяется скриптами на сайтах (вы не увидите просьбу владельцев сайта отключить блокировку рекламы)
  • Не потребляет ресурсов компьютера/смартфона
  • Можно заблокировать «сайты для взрослых»
  • Поддерживается шифрование запросов DNS для более высокой приватности
  • Это бесплатно!

Недостатки Adguard DNS:

  • Не блокирует рекламу в роликах на Youtube
  • Чтобы включить/отключить блокировку, нужно менять сетевые настройки
  • Иногда на месте рекламных баннеров возникают пустые вставки с ошибкой «не удаётся отобразить страницу».
  • Модель бизнеса Adblock понятна — они продают рекламным сетям «исключения» из бан-списков. На чём зарабатывает Adguard DNS, не понятно.

Для каждого из домашних устройств вы можете выбрать свой уровень фильтрации, например чтобы на детских планшетах отключить баннеры и взрослый контент, на рабочем компьютере достаточно будет отключить только рекламу, а на разных NAS-ах и вовсе ничего блокировать не надо.

Самое главное — Adguard DNS можно использовать вместе с Adblock по принципу двойной обороны. Друг другу эти две технологии не мешают, а скорее даже дополняют, ведь на момент подготовки статьи, Adguard DNS даже умел блокировать Яндекс Директ. Давайте посмотрим, как меняется интернет при использовании блокировщиков рекламы.

А теперь давайте посмотрим, как Adblock потребляет память компьютера, для чего в Microsoft Edge откроем следующие вкладки:

  • market.yandex.ru
  • rbc.ru
  • mail.ru
  • lenta.ru
  • zen.yandex.ru
  • auto.ru
  • avito.ru

По затратам памяти блокировщик Adblock потребляет больше, чем весит сама реклама, и это — основное ограничение, которое заставляет отказываться от данного плагина в пользу других решений.

Со смартфона блокировка работает через пень колоду: реклама то блокируется, то нет, причём это относится как к браузеру, так и к играм и прочим приложениям. Ситуацию можно выправить, если поставить рекомендуемые разработчиками сервисов Adguard браузеры — Яндекс.браузер и Samsung Internet, оба можно считать достойной заменой поднадоевшему Chrome, так что выбирайте любой. А вот с играми никакого надежного способа отключить рекламу не нашлось, но иногда она всё же пропадает, и в такие моменты телефон не хочется выпускать из рук.

Читать еще:  Управление скоростью вращения вентиляторов системного блока

Решение — бесшовные сети

Бесшовная сеть Wi-Fi — это единая сеть, которую видят устройства. Они автоматически переключаются на ту точку доступа, которая ближе, мы получаем всегда нормальный уровень сигнала. Момент переключения устройства между сетями существует, при этом у вас на секунду пропадёт связь, но не более того

Есть две категории устройств для создания бесшовного Wi-Fi: пришедшие из коммерческого сегмента (оснащение вайфаем больших площадей в коммерческих помещениях) и пришедшие из бытового сегмента. Коммерческие сети рассчитаны на большое количество точек доступа, они легко расширяются, имеют массу настроек, вследствие чего настраиваются достаточно сложно. Как правило, требуют отдельное устройство — контроллер сети. Бытовые устройства настраиваются максимально легко, но их возможности расширения гораздо слабее.

Профессиональные решения — это Ubiquiti, Cisco, Mikrotik, Edimax, Zyxel.

Бытовые решения — Keenetic (не Zyxel Keenetic), TPLink Deco, Asus Lyra, Google.

Лично я предпочитаю два варианта: Keenetic для некрупных сетей и Ubiquiti для крупных сетей с повышенными требованиями.

Подключаем управляемые точки доступа MikroTik cAP2n

Конфигурирование данных точек не вызывает никаких затруднений — интерфейс аналогичный, т.к. используется RouterOS. Единственное, на что стоит обратить внимание — это задание уникального имени каждой точки для упрощения процесса администрирования сети, а также использование назначения IP адреса автоматически от DHCP сервера. Данная настройка производится в пункте меню IPDHCP Client:

Теперь перейдем к добавлению точек MikroTik cAP2n к контроллеру Wi-Fi, как было сказано ранее — в качестве AP могут использоваться любые MikroTik с Wi-Fi модулями.

В нашем случае ap-master/controller выступает в качестве контроллера сети и одновременно с этим является управляемой точкой. Поэтому для его Wi-Fi интерфейса указываем откуда брать настройки с сети, т.е. с контроллера. Для выполнения указанной операции переходим в раздел Wireless, нажимаем CAP и ставим галочку Enabled. В поле CAPsMAN Addresses вводим IP адрес контроллера, то есть адрес этого же устройства. Обращаю внимание на то, что при подключении других точек, не являющихся одновременно контроллером, эти настройки будут немного другими. Указываем в поле Bridge Остальные поля не трогаем — нажимаем ОК.

После этого Wi-Fi адаптер подключается к нашей сети и управляется контроллером, об этом свидетельствует следующая информация:

Бесшовная Wi-Fi сеть с контроллером на базе CAPsMAN MikroTik создана, к ней можно подключаться и пользоваться. Теперь для наглядности выполним подключение еще точкек. Обновив ее до последний (или той же версии, что и контроллер), подключаем точку кабелем к роутеру (контроллеру), назначив перед этим адрес (или используем DHCP Client). После в разделе Wireless, жмем CAP. В поле Discovery Interface указываем bridge1. В нашем случае в бридж объединены все порты + wifi. В поле Bridge тоже указываем bridge1.

На вкладке Registration Table отображается информация по подключенным устройствам, при этом указывается интерфейс, к которым они подключены:

У нас 4 виртуальных интерфейса, соответствующие каждому Wi-Fi адаптеру управляемых точек доступа. Здесь можно управлять настройками этих точек. К примеру, создать разные конфигурации и здесь их распределить между точками. Распределять можно и в автоматическом режиме, на основе MAC адресов. Делается это во вкладке Provisioning.

На вкладке Radio можно увидеть соответствие точек созданным виртуальным интерфейсам:

Настройки для развертывания Wi-Fi сети на оборудовании MikroTik и пакета CAPsMAN завершены.

Освоить MikroTik Вы можете с помощью онлайн-куса «Настройка оборудования MikroTik». Курс содержит все темы, которые изучаются на официальном курсе MTCNA. Автор курса – официальный тренер MikroTik. Подходит и тем, кто уже давно работает с микротиками, и тем, кто еще их не держал в руках. В курс входит 162 видеоурока, 45 лабораторных работ, вопросы для самопроверки и конспект.

Нашли ошибку в тексте? Выделите фрагмент текста и нажмите Ctrl+Enter

Ссылка на основную публикацию
Статьи c упоминанием слов:

Adblock
detector